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Hyper-V performance comparison: Microsoft Windows
Server 2008 SP2 and R2 with Intel Xeon processor X5570-
and E5450-based servers

Executive summary

Microsoft® Corporation (Microsoft) and Intel®
Corporation (Intel) commissioned Principled
Technologies® (PT) to measure Hyper-V R2
virtualization performance improvements using
vConsolidate on the following Microsoft operating
systems and Intel processors:

e Microsoft Windows Server® 2008
Enterprise Edition SP2 with Hyper-V on
Intel® Xeon® processor E5450

e Microsoft Windows Server 2008 Enterprise
Edition SP2 with Hyper-V on Intel Xeon

processor X5570

e Microsoft Windows Server 2008 Enterprise
Edition R2 with Hyper-V on Intel Xeon

processor X5570

KEY FINDINGS

e The Intel Xeon processor X5570-based server with
the optimum number of CSUs delivered 37.1 percent
more vConsolidate performance when running
Microsoft Windows Server 2008 Enterprise Edition
R2 than when running Microsoft Windows Server
2008 Enterprise Edition SP2. (See Figure 1.)

e Microsoft Windows Server 2008 Enterprise Edition
SP2 running on the Intel Xeon processor X5570-
based server with the optimum number of CSUs
delivered 98.7 percent more vConsolidate
performance than it did running on the Intel Xeon
processor E5450-based server with the optimum
number of CSUs. (See Figure 1.)

Figure 1 shows the vConsolidate results for all three configurations with the optimum number of vConsolidate
work units, consolidation stack units (CSUs). The Intel Xeon processor X5570-based server with the optimum
number of CSUs (eight) delivered 37.1 percent more vConsolidate performance when running Microsoft Windows
Server 2008 Enterprise Edition R2 than when running Microsoft Windows Server 2008 Enterprise Edition SP2.

Microsoft Windows Server 2008 Enterprise Edition SP2 running on the Intel Xeon processor X5570-based server
with the optimum number of CSUs (eight) delivered 98.7 percent more vConsolidate performance than it did
running on the Intel Xeon processor E5450-based server with the optimum number of CSUs (three).

For complete details of the performance of each configuration at its optimum number of CSUs, see the Test

results section.

vConsolidate results

6.00

Microsoft

5.00

4.00

Windows Server
2008 R2 on
Intel Xeon

processor X5570
(8 CSUs)

3.00

Score

2.00 1

1.00 1

0.00

Server

Figure 1: vConsolidate results at the optimum number of CSUs for the three configurations we

tested. Higher scores are better.

We used a post-RC build of
Microsoft Windows Server
2008 Enterprise R2 (build
7229) that Microsoft stated
would be representative of
final performance.

The Intel Xeon processor
E5450-based server used
two processors, 16 4GB
DIMMs, an Intel PRO/1000
PT dual port NIC, and a
QLogic 4G PCI Fibre
Channel HBA. The Intel
Xeon processor X5570-
based servers used 18 4GB
DIMMs, two Intel PRO/1000
PT quad port NICs, and a
QLogic 4G PCI Fibre
Channel HBA.




Workload

Intel defined, implemented, and supplied the vConsolidate version 2.0 workload. vConsolidate includes four
different performance tests—database, Java, mail, and Web—that run simultaneously in different virtual machines
(VMs) on a server. A fifth, idle VM is also present during the test. vConsolidate refers to a single collection of
these five virtual machines as a consolidate stack unit (CSU). Depending on the type of server and its available
resources, testers can choose to run one or more CSUs. Our goal was to run enough CSUs to push the server
under test to its maximum capacity by consuming more than 98 percent of the CPU capacity.

vConsolidate sums the throughput results of each type of work across all CSUs in a test. It then amalgamates the
combined throughputs of all CSUs to create an overall score for the server under test. See the Test results
section for more information on this process.

vConsolidate uses the following four performance tests:

LoadSim

Microsoft Exchange Server 2003 Load Simulator (LoadSim) is a benchmark that measures a server’s
performance handling email. LoadSim uses the MAPI Messaging Benchmark 3 (MMB-3) to simulate MAPI email
clients. The simulated clients issue requests to an Exchange server to generate an email load. LoadSim
measures both the server’s response time and the number of messages it delivers. LoadSim is available for free
download from www.microsoft.com/downloads/details.aspx?Familyld=92EB2EDC-3433-47CA-A5F 8-
0483C7DDEAS85&displaylang=en.

SPECjbb2005

SPECjbb2005 is an industry-standard benchmark from the Standard Performance Evaluation Corp. (SPEC) that
measures a server’s Java performance. (Note: SPEC and SPECjbb2005 are trademarks of the Standard
Performance Evaluation Corporation.) SPEC modeled SPECjbb2005 on the three-tier client/server architecture,
with the middle layer as the primary focus. According to SPEC, “Random input selection represents the first (user)
tier. SPECjbb2005 fully implements the middle tier business logic. The third tier is represented by tables of
objects, implemented by Java Collections, rather than a separate database.” For more information about
SPECjbb2005, see www.spec.org/jbb2005/docs/UserGuide.html.

The results we quote here for this workload are not official SPECjbb2005 results because the vConsolidate
workload uses a slightly modified version of the benchmark. These results are not comparable to SPECjbb2005
results on SPEC’s Web site.

SysBench

The developers at SourceForge.net (www.sourceforge.net) created SysBench to test various aspects of the
performance of servers running database systems. The benchmark’s original target was the MySQL database
system (www.mysqgl.com). Intel created a version of SysBench 0.4.0 that would work with Microsoft SQL Server
2005 Enterprise Edition (www.microsoft.com/sql/editions/enterprise/default. mspx). We ran that version in our test.
In the vConsolidate workload, SysBench created a 100,000-row SQL database and executed a batch of online
transaction processing (OLTP) transactions against that data.

WebBench

WebBench 5.0 (128-bit US version) is an industry-standard benchmark for Web server software and hardware. It
uses PC clients to send Web requests to the server under test. It generates performance results by incrementally
increasing the number of clients making HTTP 1.0 GET requests to the Web server; the result is a curve showing
the server’s performance under increasing load. The peak of that curve represents the peak throughput of the
server. WebBench reports both the total number of requests per second the server handled and the server’s total
throughput in bytes per second. To be certain that we found the true peak performance in our testing, we verified
that the server’s processor utilization surpassed 98 percent during the test.
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vConsolidate profiles
The vConsolidate workload comes with four sets of VM specifications, which it calls profiles. These profiles define
five key factors for each workload VM:

number of virtual CPUs (vCPUs) the workload should receive
amount of virtual RAM (vMemory) the workload should receive
the operating system (OS) the workload should run

the key application the workload should run

the workload itself

As we noted earlier, vConsolidate refers to a single collection of these five virtual machines as a consolidate stack
unit. Depending on the type of server and its available resources, you may choose to run one or more CSUs.
vConsolidate offers four profiles; we tested with Profile 2, which we detail in Figure 2.

Profile 2
vCPUs vMemory 0S Application
WebBench (Web) 2 1.5GB Windows 32-bit IS
LoadSim (mail) 1 1.5 GB Windows 32-bit Exchange
SysBench (database) 2 1.5 GB Windows 64-bit SQL Server
SPECjbb2005 (Java) 2 2.0GB Windows 64-bit BEA JVM
Idle 1 0.4 GB Windows 32-bit NA

Figure 2: The vConsolidate profile we used in our testing.

For further information on vConsolidate, please visit http://www.intel.com/technology/itj/2006/v10i3/7-
benchmarking/6-vconsolidate.htm/.

Test results

The result for an execution of the vConsolidate workload amalgamates the results of all four of the workloads it
includes. To calculate a final score for a vConsolidate run, we used the following four steps, as vConsolidate
specifies:

Benchmark throughput = benchmark’s raw results/benchmark duration (for each of the four benchmarks)
Total benchmark throughput = add benchmark throughput for all CSUs in test

Normalized throughput = total benchmark throughput/reference system’s benchmark throughput
vConsolidate score = geomean (normalized throughput of all four benchmarks)

The first step in this process uses whatever raw results a benchmark produces, such as number of transactions or
operations, and the benchmark’s duration in seconds. We calculated a benchmark’s duration by subtracting the
start time of the vConsolidate test from its stop time and converting that time to seconds. WebBench is an
exception to this process because it automatically produces a score in requests per second. For this benchmark,
we calculated the average requests per second for the three WebBench mixes that run while the other
benchmarks are running and recorded this result as its throughput.

The second step is to sum the throughput for a given benchmark across all CSUs. In the one-CSU case, there is
no need for this step. For the two-, three-, four-, five-, six-, seven- and eight- CSU tests, we summed the
throughput of each individual benchmark across all CSUs to obtain that benchmark’s final score.

The third step is to normalize the throughput. For each of the four benchmarks for the normalization process, we
followed normal VConsolidate protocol and normalized using the Intel-provided reference scores that
corresponded with Profile 2:

e \Web: 720.99
e Java: 17119.79
e Database: 195.47
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e Mail: 15.16

We then divided the summed throughput for a given type of work by the reference score for that benchmark. This
produces the normalized score for that type of work in this test. Finally, we took the geometric mean of the
normalized throughput for all four benchmarks.

Figure 3 shows the final score (the median of three runs) and CPU utilization of the test configurations by number
of CSUs. The CPU utilization percentage is the average over the period the vConsolidate workload ran.

The optimum CSU count for the Microsoft Windows Server 2008 Enterprise Edition SP2 systems is the number of
CSUs that produces CPU utilization beyond 98 percent. For example, Microsoft Windows Server 2008 Enterprise
Edition SP2 running on the Intel Xeon processor X5570-based server surpassed 98 percent CPU utilization at
eight CSUs. The score changed minimally as we added more CSUs, which means it could still handle the load of
more virtual machines; however, its optimum score remained eight CSUs. We got our optimum CSU count for
Microsoft Windows Server 2008 Enterprise Edition R2 running on the Intel Xeon processor X5570-based server
by simply matching it with the maximum CSUs of Microsoft Windows Server 2008 Enterprise Edition SP2 running
on the Intel Xeon processor X5570-based server. We used this method because Microsoft Windows Server 2008
Enterprise Edition R2’s more efficient handling of Hyper-V allowed for increased processor utilization at lower
counts of CSUs, so stopping at 98 percent CPU utilization would have artificially limited its effectiveness.

Microsoft Windows Server Microsoft Windows Server Microsoft Windows Server
s 2008 Enterprise Edition SP2 | 2008 Enterprise Edition SP2 | 2008 Enterprise Edition R2
erver
on Intel Xeon processor on Intel Xeon processor on Intel Xeon processor
E5450-based server X5570-based server X5570-based server
No. of CSUs Score CPU Score CPU Score CPU
1 1.37 61.32 1.32 31.51 1.63 24.77
2 1.92 92.56 2.58 60.44 3.23 49.13
3 2.07 98.01 3.05 75.80 4.30 72.61
4 3.38 84.10 4.88 87.80
5 3.66 91.68 5.19 93.81
6 3.86 93.55 5.40 96.76
7 3.97 96.24 5.49 98.34
8 411 98.21 5.64 99.05

Figure 3: vConsolidate results for the three test configurations with varying numbers of CSUs with corresponding CPU utilizations.
Higher scores are better.

Figure 4 shows the three-CSU test results, by benchmark and CSU, for Microsoft Windows Server 2008
Enterprise Edition SP2 running on the Intel Xeon processor E5450-based server.

Microsoft Windows Server 2008

Enterprise Edition SP2 on Intel Xeon | Database Java Mail Web Final score
processor E5450-based server

CSuU 1 63.65 16,145.53 18.41 442.03

CSU 2 66.20 16,246.31 17.90 432.53

CSU 3 65.86 16,220.78 18.13 430.75 2.07

Figure 4: vConsolidate three-CSU median results, by benchmark and CSU, for Microsoft Windows Server 2008 Enterprise Edition
SP2 running on the Intel Xeon processor E5450-based server. Higher scores are better.

Figure 5 shows the eight-CSU test results, by benchmark and CSU, for Microsoft Windows Server 2008
Enterprise Edition SP2 running on the Intel Xeon processor X5570-based server.
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Microsoft Windows Server 2008

Enterprise Edition SP2 on Intel Xeon | Database Java Mail Web Final score
processor X5570-based server

CSU 1 34.01 7,871.19 18.71 348.61

CSU 2 34.69 14,047.38 15.60 335.54

CSU 3 36.60 7,937.51 16.99 348.26

CSuU 4 35.14 12,197.40 17.63 235.18

CSU 5 37.23 7,895.59 17.54 232.04

CSU 6 35.83 12,065.54 16.27 317.01

Csu7r 70.23 11,987.50 18.31 350.37

CSU 8 68.15 12,336.90 16.67 351.88 4.11

Figure 5: vConsolidate eight-CSU median results, by benchmark and CSU, for Microsoft Windows Server 2008 Enterprise Edition

SP2 running on the Intel Xeon processor X5570-based server. Higher scores are better.

Figure 6 shows the eight-CSU test results, by benchmark and CSU, for Microsoft Windows Server 2008
Enterprise Edition R2 running on the Intel Xeon processor X5570-based server.

Microsoft Windows Server 2008

Enterprise Edition R2 on Intel Xeon Database Java Mail Web Final score
processor X5570-based server

CSuU 1 58.69 10,340.09 17.08 769.18

CSsuU 2 60.24 9,316.49 17.78 774.58

Csu3 71.32 10,797.00 16.15 765.17

Csu 4 58.18 10,874.07 18.14 776.62

CsSuUus5 60.99 10,670.48 16.48 779.60

CSuU 6 70.94 11,007.45 17.81 770.96

Csu7 71.09 11,113.09 18.28 906.60

CSU 8 61.77 9,839.52 15.02 776.20 5.64

Figure 6: vConsolidate eight-CSU median results, by benchmark and CSU, for Microsoft Windows Server 2008 Enterprise Edition
R2 running on the Intel Xeon processor X5570-based server. Higher scores are better.

We include complete results for all runs on the three test systems in Appendix B.

Note: Due to the complexity and number of components the vConsolidate benchmark uses (e.g., network
interfaces, client computers, storage sub-system, configuration of VMs, and benchmark components), Intel does
not recommend directly comparing test results from this report with results from other vConsolidate reports.
Unless the benchmark and its components have identical configurations, results may vary, providing an
inadequate basis for direct comparison.

Test methodology

Intel provided all servers. With the following exception, we used the default BIOS settings on each server: we
enabled Intel Virtualization Technology and disabled Turbo mode on both Intel Xeon processor X5570-based
setups to match the Windows Server 2008 R2 shipping settings. (Default power policy disables Turbo mode on
Intel Xeon processor X5570-based systems because it consumes more power at medium-to-high utilization
levels. Administrators can change the server power policy to High Performance, the least power-efficient setting.
Doing this enables Turbo mode.)

To be sure we could push the processors of each of the three system configurations to their maximum capacities,
we tested each server with as many vConsolidate CSUs as the server could reasonably handle, starting with one
CSU, up to or just over 98 percent processor utilization. The rest of this section details how we set up the servers
and the vConsolidate workload.
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Hardware and software the test involved
Software
We used the following software to configure and run the vConsolidate workload:

Windows Server 2008 Hyper-V

Windows Server 2008 Hyper-V R2

Microsoft Windows Server 2003 R2, Enterprise Edition
Microsoft Windows Server 2003 R2, Enterprise x64 Edition
Microsoft Exchange Server 2003

Microsoft SQL Server 2005

BEA JRockit 1.6.0_02-b05

WebBench 5.0

Microsoft Exchange Server Load Simulator (LoadSim) 06.05.7775
SPECjbb2005 v1.07

SysBench v0.4.0

Intel vConsolidate OEM framework package version 2

Hardware
Our test bed consisted of the following hardware:

The server under test

Eight custom-built client systems with Intel Pentium E2180 2.0GHz systems, which we used for the main
vConsolidate controller as well as all of the WebBench clients, LoadSim clients, and WebBench
controllers

NETGEAR GS724T

EMC CLARIiion CX3 storage

Seven EMC CX-4PDAE-FD disk enclosures and 32 x Hitachi HUS151473VLF4EQ 73.4GB disk drives
QLogic SANblade QLE2462 Dual Port 4-Gbps Fibre Channel Host Bus Adapter (HBA), which we installed
in the server under test

Figure 7 illustrates the vConsolidate test bed.

-7/

vConsolidate test bed

CSU #n Combined |IP addresses

Internal network client Server under test
\ switch (WebBench « External network IP address: 192.168.0.250
\ controller,
WebBench client, |Main controller
and LoadSim « External network IP address: 192.168.0.100
client) « Internal network IP address for each CSU's

LoadSim and WebBench traffic: in form
192.168.n1.100, where n is CSU number (e.g.,
CSU #1 = 192.168.11.100)

-——( Internal network n
——{(  External network

Internal network IP addresses
« Combined client: in form 192.168.n1.110, where n
is CSU # (e.g., CSU #1 =192.168.11.110)

VM IP addresses
« Mail server VMs: in form 192.168.n1.115, where n
is CSU # (e.g., CSU #1 = 192.168.11.115)
external network and one « Web server VMs: in form 192.168.n1.215, where n
NIC per CSU for is CSU# (e.g., CSU #1 = 192.168.11.215)
WebBench and LoadSim « JavaServer1 - n, DBServer1 - n, IdleServer1 — n
traffic (where n is highest CSU#) = DHCP

Server under test
with one active NIC for

Figure 7: Our vConsolidate test bed.
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Server installation
We configured all servers with the same disk setup using the EMC CLARIiion CX3. We split the storage into eight
volumes with 133 GB. For each server, we installed a CSU on each of the 133GB volumes.

Adding the Hyper-V role to Windows Server 2008
Note: Make sure you have installed all the latest critical and recommended updates for Windows Server 2008
from Windows Update.

1. Click Server Manager->Roles—>Add Roles.

2. Check the box beside the Hyper-V role, and click Next.

3. Click Next.

4. Check the box beside the Ethernet card you wish to use, and click Next.

5. Click Install. Installation begins.

6. When installation finishes, click Close.

7. When the system prompts you to restart, click Yes.

8. Once the system finishes rebooting (this might happen twice), log in. The Resume Configuration Wizard
should start automatically.

9. Once the Resume Configuration Wizard completes, the installation results should appear with a message
that the installation succeeded.

10. Click Close.

11. Restart the server.

Adding logical unit numbers (LUNs)
Note: Make sure that you have mapped the Fibre Channel LUN to the card in your system.

1.
2.

Noos~®

®

Click Server Manager-> Storage—>Disk Management.

When the wizard prompts you to initialize new disks, click OK. Note: If you must select a partition table,
select MBR.

Right-click the first unallocated disk partition, and select New Simple Volume...

Click Next.

Use the entire LUN storage space (this should be the default), and click Next.

Select the drive letter to assign to the new partition, and click Next.

Label the volume appropriately (e.g., LUNO, LUN1, etc.), make sure Perform a quick format is checked,
and click Next.

Click Finish.

Configuring Hyper-V default options

1.

2.
3.

4.

5.
6.

Click Start->Administrative Tools>Hyper-V Manager.

From the Actions menu, select Hyper-V Settings...

From the left menu of the Settings screen, select Virtual Hard Disks, and enter the default folder to store
virtual hard disk files (e.g., E:\Hyper-V\Virtual Hard Disks).

From the left menu of the Settings screen, select Virtual Machines, and enter the default folder to store
virtual hard disk files (e.g., E:\Hyper-V).

Click OK.

You may also want to configure any VM network switch settings at this time.

Creating a virtual machine

1.

pOD

©ooNO

Click Start->Administrative Tools->Hyper-V Manager.

From the Actions menu, select New->Virtual Machine...

Click Next.

Enter a name for the virtual machine, and browse to the location where you want to store the VM files.
(The New Virtual Machine Wizard will automatically create a subfolder with the name of the VM.)
Click Next.

Specify the amount of memory to allocate to the virtual machine, and click Next.

Select the network connection for the virtual machine to use, and click Next.

Select Attach a virtual hard disk later, and click Next.

Click Finish.

Principled Technologies, Inc.: Hyper-V performance comparison: Microsoft Windows

Server 2008 SP2 and R2 with Intel Xeon processor X5570- and E5450-based servers



Modlfylng the Virtual Machine (Creating the virtual HDD)

Click Start->Administrative Tools>Hyper-V Manager.

Right-click the virtual machine on which you want to install Windows, and click Settings...
From the menu on the left, select IDE Controller 0, and click Add to add a new hard drive to the IDE
Controller.

4. Click New to create a new virtual hard disk file.

5. Click Next.

6. Select Fixed size, and click Next.

7. Specify the name and location of the virtual hard disk file.

8

9.

1

W=

Specify the size of the new blank virtual hard disk (in GB).
Click Finish. The server begins creating the new virtual hard disk.
0. Once it finishes creating the new virtual hard disk, click OK.

Modifying the Virtual Machine (adding an additional hard disk)

Note: Do not use this method to configure the VM primary hard disk; for that you must use a virtual IDE hard disk.
However, we recommend that you perform high-usage I/O tasks (e.g., database server, file server, mail server,
etc.) on a secondary disk whenever feasible.

Click Start>Administrative Tools=>Hyper-V Manager.

Right-click the virtual machine on which you want to install Windows, and click Settings...

From the menu on the left, select Add Hardware.

Choose the SCSI Controller device, and click Add.

Click Add to add a new hard drive to the virtual SCSI Controller.

Click New to create a new virtual hard disk file.

Click Next.

Select Fixed size, and click Next.

Specify the name and location of the virtual hard disk file.

10 Specify the size of the new blank virtual hard disk (in GB).

11. Click Finish. The server will then begin creating the new virtual hard disk.

12. Once it finishes creating the new virtual hard disk, click OK.

©CoNO>ORA~®LN =

Installing Windows on the VM
Click Start->Administrative Tools->Hyper-V Manager.
Right-click the virtual machine on which you want to install Windows, and click Connect...
From the menu, select Media->DVD Drive—>Insert Disk...
Select the ISO image file for the version of Windows you are installing, and click Open.
To start the virtual machine, select Start from the Action menu.
Click the screen, and begin installing Windows as you normally would.
Once installation is complete, select Action—-> Ctrl-Alt-Delete.
Enter your password, and press Enter.
Select Media>Eject CD.
. Select Media—>Insert CD, and choose the second installation disk.
. When the Windows installation completes, select Action—>Insert Integration Services Setup Disk from the
menu. Installation should begin automatically.
. At the prompt to restart, click Yes.
. Once the system has restarted, log in, and verify that all configured devices (mouse, keyboard, video,
network, etc.) are working.
. Once you are sure all your devices are working, from the menu, select Media->DVD Drive>Eject
vmguest.iso.
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To create one vConsolidate CSU, we had to create the five virtual machines that CSU describes:

e mail server
e Web server
e Java application server
e database server
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idle server

The following subsections detail how we created and configured each of these VMs.

Installing and configuring the mail server VM
Follow the steps in the earlier Copying the VMs section using the following VM specifications:

Base VM: Base32

Name: MailServer1

Virtual processors: 1

Virtual memory: 1.5 GB

Virtual disk size: 10 GB

Virtual network: Internal Network (set the IP address to 192.168.11.115 in Windows within the VM)

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing the domain controller

©CoNooA~WON =

15.

16.
17.
18.
19.
20.

Select Start->Administrative Tools->Manage Your Server.

Click Add or remove a role.

At the Configure Your Server window, click Next.

At the Configuration and Options screen, select Custom Configuration, and click Next.

At the Server Role screen, select Domain Controller, and click Next.

At the Summary of Selections screen, click Next.

At the Welcome pop-up window, click Next.

At the Operating System Compatibility screen, click Next.

For the Domain Controller Type, leave the default option (Domain controller for a new domain), and click
Next.

. At the Create New Domain screen, leave the default (Domain in a new forest), and click Next.

. At the Install or Configure DNS window, select No, and click Next.

. At the New Domain Name screen, type a domain name (vcon . com), and click Next.

. At the NetBIOS Domain Name screen, type a NETBIOS domain name (vcon), and click Next.

. Click Next through the following screens: Database and Log Folders, Shared System Volume, and

Permissions. Doing so accepts the default options for each of those screens.

At the Directory Services Restore Mode Administrative Password screen, type a password (password),
and click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.

At the Completing the Active Directory Installation Wizard screen, click Finish.

When the system prompts you to reboot the VM, click Restart Now.

After the VM reboots, log into the system.

At the This Server is Now a Domain Controller window, click Finish.

Installing Internet Information Services 6.0

©CoNooOA~LON =

10.
11.

Select Start->Control Panel=>Add or Remove Programs.

Click Add/Remove Windows Components.

Select Application Servers, and click Details.

Click ASP.NET, and make sure a check appears in the check box.
Select Internet Information Services (IIS), and click Details.

Click NNTP Services and SMTP Services, make sure a check appears in both check boxes, and click OK.
Click OK to close the Application Server window.

At the Windows Components Wizard, click Next to begin the installation.
When the system prompts you to do so, insert the OS CD, and click OK.
At the Completing the Windows Components Wizard window, click Finish.
Close the Add or Remove Programs window.
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Installing Exchange Server 2003

1.

Nooh~ON

10.
11.

12.

T Taemoeo

Insert the Microsoft Exchange Server 2003 CD. The CD should automatically launch the installation
software.

Choose Exchange Server Enterprise Edition.

Run the Setup application.

Click the Exchange Deployment Tools link.

Click the Deploy the first Exchange 2003 Server link.

Click the New Exchange 2003 Installation link.

Click the Run ForestPrep now link.

a. When the compatibility issue notice appears, click Continue, and check the Don’t display this
message again box.

At the Welcome screen, click Next.

Accept the End User License Agreement, and click Next.

At Component Selection Screen, keep the defaults, and click Next.

Leave the default account information, and click Next.

Installation should start. (This process may take a while to complete.)

When the installation completes, click Finish.

Return to the Exchange Server Deployment Tools screen, and click the Run DomainPrep Now link.
a. Atthe Welcome screen, click Next.

b. Accept the End User License Agreement, and click Next.

c. At Component Selection Screen, keep the defaults, and click Next.

d. At the insecure domain notice, click OK.

e. When the installation completes, click Finish.

Return to the Exchange Server Deployment Tools screen, and click Run Setup Now.

a. Atthe Welcome screen, click Next.

b. Accept the End User License Agreement, and click Next.

@*pooyo

c. Atthe Component Selection screen, the action for Microsoft Exchange should by default be Typical.

(If it is not, use the drop-down box to set it to Typical.)

Click Next.

For the Installation Type, select Create new Exchange Organization, and click Next.
Type vcon as the Organization Name, and click Next.

Accept the Microsoft Exchange Server Licensing Agreement, and click Next.

Review the installation summary, and click Next.

The installation should start. (This process may take a while to complete.)

When the installation completes, click Finish.

Close the Exchange Server Deployment Tools window.

Install Microsoft Exchange Server 2003 Service Pack 2.

Insert the SP2 CD, and double-click update exe.

Accept the default location to extract the file, and click OK.

After the extraction finishes, open Windows Explorer, and browse to the update.exe executable.
At the Welcome screen, click Next.

Select | agree to accept the License Agreement, and click Next.

At the Component Selection window, leave the default option (Update), and click Next.
Verify the installation Summary, and click Next.

When the installation completes, click Finish.

In the Virtual Infrastructure Client console, add a new 40GB virtual hard disk to this VM by doing the
following:

Right-click the MailServer1 VM, and select Settings from the menu.

On the Hardware Tab, click Add Hardware.

Choose the SCSI Controller device, and click Add.

Click Add to add a new hard drive to the virtual SCSI Controller.

Click New to create a new virtual hard disk file.

Click Next.

Select Fixed size, and click Next.

Specify the name and location of the virtual hard disk file.

S@ 000 oTw
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13.
14.
15.
16.
17.
18.
19.
20.
21.
22.
23.
24.
25.
26.
27.
28.
29.
30.
31.
32.
33.
34.
35.
36.
37.
38.
39.
40.
41.

42.
43.
44.
45.
46.
47.
48.
49.
50.
51.
52.
53.
54.
55.

i. Specify the size of the new blank virtual hard disk (in GB).

j.  Click Finish. The server will then begin creating the new virtual hard disk.

k. Once it finishes creating the new virtual hard disk, click OK.

Restart the VM by selecting Start->Shut down—->Restart inside the MailServer VM.

In the MailServer VM, right-click My Computer, and select Manage.

In the Computer Management Console, select Disk Management.

When a Welcome to Initialize and Convert Disk Wizard window appears, click Next.

Select Disk 1 to initialize.

At the Select Disk to Convert screen, leave the disk unchecked.

At the Completing the Initialize and Convert Disk Wizard screen, click Finish.

Right-click the Disk 1 unallocated box, and select New Partition.

At the Welcome screen, click Next.

Leave the partition type as Primary, and click Next.

Accept the default partition size, which should be the same as the Maximum disk space, and click Next.
Assign the drive letter E, and click Next.

Format the partition with the NTFS File system, type Mail Store for the volume label, and click Next.
At the Completing the New Partition Wizard screen, click Finish. The partition should begin formatting.
When the formatting completes, close the Computer Management console.

Select Start->All Programs—>Microsoft Exchange—> System Manager.

In the left window pane, expand Servers and MailServer so the First Storage Group is visible.
Right-click First Storage Group, and select Properties.

Click Browse, and change the Transaction log and System path location to E:\.

Check the Enable circular logging box, and click Apply.

When the pop-up message appears asking if you want to perform this task, click Yes.
When the message appears saying that all mounted stores are back online, click OK.
Right-click Mailbox Store under First Storage Group, and select Properties.

Select the Database tab.

Click Browse, and move the Exchange database and Exchange streaming database to E:\.
Check the This database can be overwritten by a restore box.

Click Customize next to Maintenance interval.

Remove all blue from the boxes so the system will not perform maintenance, and click OK.
At the Mailbox Store Properties window, click Apply.

When a warning message appears, click Yes.

When the message that the database files have been moved appears, click OK.

Click OK to close the Mailbox Store Properties window.

Right-click Public Store under First Storage Group, and select Properties.

Select the Database tab.

Click Browse, and move the Exchange database and Exchange streaming database to E:\.
Check the This database can be overwritten by a restore box.

Click Customize next to Maintenance interval.

Remove all blue from the boxes so the system will not perform maintenance, and click OK.
At the Public Store Properties window, click Apply.

When a warning message appears, click Yes.

When the message that the database files have been moved appears, click OK.

Click OK to close the Public Store Properties window.

Reboot the virtual machine.

Installing and configuring the Web server VM
Follow the steps in the earlier Cloning the base VMs section using the following VM specifications:

Source VM: Base32

Name: WebServer1 (use WebServer for the Host Name in the VM)
Virtual processors: 2

Virtual memory: 1.5 GB

Virtual Disk Size: 10GB
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Virtual Network: Internal Network (set the IP address to 192.168.11.215 in Windows within the VM)

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing Microsoft Internet Information Server

1.
2
3
4
5.
6.
7
8
9.
1

0.

Select Start->Administrative Tools->Manage Your Server.

Select Add or remove a role.

At the Configure Your Server window, click Next.

At the Configuration Options screen, select Custom configuration, and click Next.

At the Server Role screen, select Application Server, and click Next.

At the Application Server Options screen, select Enable ASP.NET, and click Next.

At the Summary of Selections screen, click Next.

When the installation software prompts you to do so, insert the Operating System CD, and click OK.
When the installation completes, click Finish.

Close the Manage Your Server window.

Installing WebBench 5.0

1.
2.
3.

S

T200oNe

12.
13.
14.
15.

16.
17.
18.
19.
20.
21.
22.
23.
24.
25.

26.

0.
1. Using Windows Explorer, browse to C:\Inetpub\wwwroot\cgi-bin, right-click simcgi.exe, and select

Insert the WebBench 5.0 CD into the Virtual Client, and connect with the Virtual COROM.

Copy wbtree.exe from the \wb50\workload directory on the CD to C:\inetpub\wwwroot.

Double-click wbtree.exe to expand the workload. (This step will create a wbtree folder with all the test
data WebBench required.)

Create a cgi-bin folder in c:\inetpub\wwwroot.

After installing the WebBench controller, copy simcgi.exe from the controller machine in
C:\WebBench\Controller\Suites\WebBench\Examples directory to the Web server VM’s
C:\Inetpub\wwwroot\cgi-bin\ directory.

Right-click My Computer, and select Manage.

Expand Services and Applications, Internet Information Services, and Web Sites in the left window pane.
Click Default Web Sites.

Right-click the cgi-bin directory in the right pane, and select Properties from the drop-down menu.

In the Execute permissions field, select Scripts and Executables, and click OK.

Properties from the drop-down menu.

Select the Security tab, and grant Read/Read & Execute permissions to the user, Internet Guest Account.
Click OK to close simcgi.exe properties.

Close Windows Explorer.

In the Computer Management window, right-click the Default Web Server, and select properties from the

drop-down menu.

Select the HTTP Headers tab, and click MIME Types.

In the MIME Types window, click New.

In the Extension text box, type .ex

In the MIME type text box, type application/octet-stream and click OK.

Click OK again to close the MIME Types window and the Default Web Site Properties window.

If a notification window about a child node pops up, click OK.

In the Computer Management console, select Web Service Extension.

Select All unknown CGI Extensions in the right pane, and click Allow.

Click Yes, you do want to allow All Unknown CGI Extensions in the pop-up window.

Open a Web browser, and type the URL http://localhost/cgi-bin/simcgi.exe to verify you correctly installed
the WebBench files. Text about the system should appear in the browser window.

Close the Web browser.

Installing Certificate Server

1.

Select Start->Control Panel->Add or Remove Programs.

2. Click Add/Remove Windows Components.
3. Select Certificate Servers, and accept the CA Service warning.
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Click Next.

Select Standalone root CA in the CA Type Windows, and click Next.

Type WEBBENCH in the common name field, and click Next.

At the Certificate Database Settings screen, leave the default options, and click Next.
When the warning about stopping IIS appears, click Yes.

When the installation software prompts you to do so, insert the OS CD, and click OK.
10 Click Yes to enable Active Server Pages.

11. When the installation completes, click Finish.

©oNOOA

Creating a certificate request

1. In the Computer Management Console, right-click the Default Web site, and select Properties.

2. Select the Directory Security tab, and then click Server Certificate under Secure Communications to start
the Web Server Certificate Wizard.

3. Atthe Welcome screen, click Next.

4. Select Create a new certificate, and click Next.

5. Select Prepare the request now, but send it later, and click Next.

6. Type Default Web Site forthe certificate name.

7. Use the default bit length (1024), and click Next.

8. Type MyWeb for the organization name and Development Dept for the organizational unit, and click
Next.

9. Enter the server name as the common name, and click Next.

10. Enter your location information, and click Next.

11. Save the certificate information to the default path and file name, and click Next.

12. Verify the information that you have typed, and then click Next to complete the process and create the
certificate request.

13. Click Finish to close the IIS Certificate Wizard.

14. Click OK to close the Default Web Site Properties window.

Submitting a certificate request

1. Open a Web browser, navigate to http://localhost/CertSrv/, and press Enter.
2. Click Request a certificate.
3. Click Advanced certificate request.
4. Click Submit a certificate request by using a base-64-encoded CMC or PKCS #10 file, or submit a
renewal request by using a base-64-encoded PKCS #7 file.
5. Open the request document that you created in the Create a certificate request section.
6. Copy the contents of the document to a text box with the following format:
I BEGIN NEW CERTIFICATE REQUEST-----
* ...
I END NEW CERTIFICATE REQUEST-------
Note: If you saved the document with the default name and location, it is located at C:\Certreq.txt. Be sure
to copy all of the content as we illustrated above.
7. Paste the contents of the document into the Web form’s Base64 Encoded Certificate Request text box.
8. Click Submit.
9. You should receive a Certificate Pending message in the Web browser.
10. Close the Web browser window.

Issuing and downloading a certificate
1. Select Start->All Programs-> Administrative Tools-> Certificate Authority.
2. In the Certificate Authority window, expand the server name.
3. Click the Pending Requests folder.
4. In the pending request folder, right-click the pending certificate request that you just submitted, select All
Tasks, and then click Issue. (Note: After you select Issue, the certificate no longer appears in this window
and folder. It now resides in the Issued Certificate folder.)
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Close the Certificate Authority window.

Open a Web browser, and type http://localhost/CertSrv/
Click View the status of a pending certificate request.

Click the certificate request that you can see.

Click Download Certificate.

. Click Save in the File Download window.

. Save the certificate to C:\.

. Close the download complete pop-up window.
. Close the Web browser window.

Installing the certificate and setting up an SSL Web site

PN~

Noou

8.
9.
10.
11.

12.

Open the Computer Management console by right-clicking My Computer and selecting Manage.
Right-click the Default Web site, and select Properties.

Select the Directory Security tab.

Under Secure Communications, click Server Certificate. This step will start the Certificate Installation
Wizard.

At the Welcome screen, click Next.

Select Process the pending request and install the certificate, and click Next.

Browse to the location of the certificate that you downloaded in the Issue and download a certificate
section, and click Next.

Keep the default SSL Port, and click Next.

Verify the information is correct on the Certificate Summary page, and click Next.

Click Finish to complete the installation.

Click OK to close the Default Web Site Properties window.

Close the Computer Management window.

Configuring and testing the certificate

1.
2.

3.
4.

Open a Web browser, and type https://webserver/cgi-bin/simcgi.exe

You may receive a security alert that states that the certificate is not from a trusted root CA. Click Yes to

continue to the Web page.
If the page appears, you have successfully installed the certificate.
Close the Web browser.

Installing and configuring the Java application server VM
Follow the steps in the earlier Cloning the base VMs section using the following VM specifications:

Base VM: Base64

Name: JavaServer1

Virtual processors: 2

Virtual memory: 2 GB

Virtual Disk Size: 10 GB

Virtual Network: External Network (keep the default Windows Network DHCP settings)

To finish setting up this VM for vConsolidate, we had to install and modify an additional software component. The
following subsections detail the necessary installation processes.

Installing SPECjbb2005

1.
2.
3.

Copy the BEA JRockit JVM 1.6.0_02 folder to the root of C: in the VM.

Install SpecdBB2005 in the VM directory: c:\vSpecJBB2005.

Add the BEA JRockit JVM to the Windows system path by doing the following:
a. Right-click My Computer, and select Properties.
b. Select the Advanced tab, and click Environment Variables.
c. Inthe System variables section, select Path, and click Edit.
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d. Add the following to the end of the Variable value string: C:\jrockit-jdk1l.6.0 02 \bin
(jrockit-jdk1.6.0_02 is the folder name of the JVM installation).
e. Click OK to close the Edit System Variable, Environment Variables, and System Properties
windows.
4. Open a command prompt by selecting Start>Run.
5. Type cmd and click OK.
6. Change to the vSpecJBB2005 directory by typing cd C:\vSpecdBB2005 and pressing Enter.
7. Type runit .bat and press Enter to verify that SPECjbb2005 starts.
8. Press Cirl-C to stop the benchmark.
9. Confirm that you do want to stop the run by typing Y and pressing Enter.
10. Copy the following files from the vConsolidate package to the VM directory C:\:
e Daemon.exe
e Kkillapp.exe

Modifying SPECjbb2005
To run the vConsolidate benchmark, you must modify SPECjbb2005 as follows:
1. Modify the following three original source files in the SPECjbb directory (C:\vSPECjbb2005\src\spec\jbb\)
by opening each file with WordPad and making the changes below. Save each file after you have made
the changes.

e Company.java
Change private long measurement time; to public long measurement time;
Change UBButil.SecondsToSleep ( (int) measurement time); to
JBButil.SecondsToSleep (Long.MAX VALUE/1000) ;
e DeliveryTransaction.java
After the line customerPtr.adjustBalance (matchingOrder.getTotalAmount () ) ;
Add the following lines:
int timerCount = 0;
timerCount = (short)JBButil.random(1,100);
if (timerCount == 1)
JBButil.milliSecondsToSleep (company.measurement time) ;
e TransactionManager.java
Change myTimerData.updateTimerData (txntype, txntime); to the following lines:

myTimerData.updateTimerData (txntype, txntime) ;

if (txntype==0 && myTimerData.getTransactionCount (0) %1000 == 0)
int sum = 0;
for (int k=0; k<=5; k++)

sum += myTimerData.getTransactionCount (k) ;

System.out.println("===="+this+":"+"===="+sum) ;

}

}

Open the command prompt by clicking Start->Run, type cmd and press Enter.
3. Atthe command prompt, type cd C:\vSPECjbb2005\src\spec\jbb\
4. At the command prompt, type the following commands. Press Enter after each command:

N

e mkdir class

e "C:\Program Files\Java\jrockit-jdkl.6.0 02\bin\javac" -cp "C:\Program
Files\Java\jrockit-jdkl.6.0 02\jre\lib\rt.jar" -d class\ *.java
infra\Util\*.java validity\*.java ..\reporter\*.java

e cd class\

e "C:\Program Files\Java\jrockit-jdkl.6.0 02\bin\jar" -cf jbb.jar
spec\jbb\*.class spec\jbb\infra\Util\*.class spec\reporter\*.class
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e "C:\Program Files\Java\jrockit-jdkl.6.0 02\bin\jar" -cf check.jar
spec\jbb\validity\*.class

Type exit to close the command prompt.

Open Windows Explorer from the start menu.

Copy the jbb.jar and check jar files from C:\vSPECjbb2005\src\spec\jbb\class to C:\vSpecJBB2005\.
When the system asks if you want to overwrite files, click Yes to overwrite the original jbb.jar and
check.jar files.

Using Windows Explorer, navigate to C:\vSpecJBB2005, and open the SPECjbb.props file.

0. Make the following changes to the SPECjbb.props file:

©® N O

- ©

e Change input.starting number warehouses=1 to
#input.starting number warehouses=1

e Change input.increment number warehouses=1 to
#input.increment number warehouses=1

° Change#input.sequence_of_number_of_warehouses=1 23456 7 8t
input.sequence of number of warehouses=2
Note: Set the above parameter to be equal to the number of vCPUs you configured for Java server
VM.

e Change input .measurement seconds=240 {0 input.measurement seconds=10

11. In the C:\vSpecJBB2005 directory, right-click runit.bat, and change set JAVAOPTIONS=-Xms256m -

Xmx256m t0 set JAVAOPTIONS=-Xmsl000m -Xmx1000m -Xxthroughputcompaction -

XXallocprefetch -XXallocRedoPrefetch -XXcompressedRefs -XxlazyUnlocking -

XXtlasizel28k

Installing and configuring the database server VM
Follow the steps in the earlier Cloning the base VMs section using the following VM specifications:

Base VM: Base64

Name: DBServer1

Virtual processors: 2

Virtual memory: 1.5 GB

Virtual disk size: 10 GB

Virtual network: External Network (keep the default Windows Network DHCP settings)

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing Microsoft Internet Information Server

Select Start->Administrative Tools->Manage Your Server.

Select Add or remove a role.

At the preliminary steps screen, click Next.

At the Server Role screen, select Application Server, and click Next.

At the Summary of Selections screen, click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.
When the installation completes, click Finish.

Close the Manage Your Server window.

N>R WON =

Installing Microsoft SQL Server 2005

Insert the SQL Server 2005 CD into the controller, and connect with the Virtual CD ROM.
Click the Server Components link under the Install section to begin the installation.
Accept the license agreement, and click Next.

Click Next to install the prerequisites.

After the prerequisites complete installing screen, click Next.

arON =
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At the Welcome screen, click Next.

At the System Configuration Check, assuming everything has a status of success, click Next.
Enter the registration information, and click Next.

At the Components to Install screen, select SQL Server Database Services, and click Advanced.

. Instruct the software to install both the Database Services and Client Components by clicking the drop-

down arrow on both and selecting Entire feature will be installed on local hard drive.

. Click Next to start the installation.

. For Instance Name, leave the default option, and click Next.

. At the Service Account screen, select Use the built-in system account (Local system), and click Next.

. Keep the default option for Authentication Mode, and click Next.

. For Collation Settings, leave the defaults, and click Next.

. Accept the default Error and Usage Report Settings, and click Next.

. At the Ready to Install screen, click Install to begin the installation.

. When the installation software prompts you to do so, insert Microsoft SQL Server 2005 Disk 2. Use the

Virtual CDROM to connect it to the VM, and click OK.

. When the setup process completes, click Next.

. Click Finish to complete the initial installation.

. Install Service Pack 3 by copying SQLServer2005SP3-KB955706-x64-ENU.exe to the virtual machine.
. Double-click the executable to launch the installer.

. At the Welcome screen, click Next.

. At the License Terms screen, accept the license agreement.

. At the Feature Selection screen, click Next to accept all defaults.

. At the Authentication screen, click Next to accept all defaults.

. At the Error and Usage Reporting Settings screen, click Next to accept all defaults.

. At the Running Processes screen, click Next.

. At the Ready To Install screen, click install.

. At the Computer Reboot Required message box, click OK.

. At the Installation Complete Screen, click Next.

. At the Additional Information screen, deselect Launch the User Provisioning Tool for Windows Vista after

SP3 installation completes.

. Click Finish.

Creating the test database and generating data

1.
2.

©OoN>O AW

10.
11.
12.

13.
14.

Select Start->Microsoft SQL Server 2005->SQL Server Management Studio.

In the Connect to Server window, use the drop-down menu next to Server name to select <Browse for
more>.

In the Browse for Server window, select the Network Servers tab, and wait for it to retrieve data.
When Database Engine appears, expand the menu, select DBSERVER1, and click OK.

At the Connect to Server window, the server name should be present.

Click Connect to connect to the server.

Right-click the Database folder in the left window, and select New Database from the pop-up menu.

In the Database name field, type sbtest and click OK.

Copy the following files from the vConsolidate package to the VM C:\ directory:

e vSysbench.exe
e Daemon.exe
e Kkillapp.exe

Open a command prompt by selecting Start>Run, type cmd and click OK.

In the command prompt, type cd \ to change to C:\.

To prepare the database, type vsysbench.exe --test=oltp --oltp-table-size=100000
prepare and press Enter.

When the command finishes, the C:\ prompt appears.

Type exit and press Enter to close the command prompt.
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15. In SQL Server 2005 Management Studio, stop the database service by right-clicking DBSERVER1 in the
left window pane, and select Stop from the drop-down menu.

16. Using Windows Explorer, create the folder C:\sysbench_backup.

17. With Windows Explorer, copy all sbtest files from C:\Program File\Microsoft SQL
Server\MSSQL.1\MSSQL\Data\ to c:\sysbench_backup. (You should see two files: sbtest. mdf and
sbtest_log.Idf.)

18. Once the copy completes, close Windows Explorer.

19. Restart the database service using SQL Server 2005 Management Studio by right-clicking DBSERVER1
and selecting start.

Installing and configuring the idle server VM
Follow the steps in the earlier Cloning the base VMs section using the following VM specifications.

Base VM: Base32

Name: IdleServer1

Virtual processors: 1

Virtual memory: 0.4 GB

Virtual disk size: 5 GB

Virtual network: External Network (keep the default Windows Network DHCP settings)

Installing and configuring the second CSU
To create the VMs the second CSU requires, we exported our first CSU and used that to import our future CSUs.
We then started each VM and entered a new IP address or host name depending on the need of each VM.

Exporting VMs on Microsoft Windows Server 2008 SP2
You will need to export your first CSU as many times as there are CSUs that you wish to test.
1. Right-click the VM that you wish to export.

2. Click Export...
3. Enter the location you would like to export your VMs to, and click Export.

Importing VMs on Microsoft Windows Server 2008 SP2
1. Click Action-->Import Virtual Machine...

2. Click Browse.

3. Browse to where you exported your VM, select the VM Folder you wish to copy out, and click Select
Folder.

4. Click Import.

5. Repeat this task until you have imported all five VMs.

Exporting VMs on Microsoft Windows Server 2008 R2
R2 allows the user to export the first CSU once and then use that export for all future imports.
1. Right-click the VM that you wish to export.

2. Click Export...
3. Enter the location you would like to export your VMs to, and click Export.

Importing VMs on Microsoft Windows Server 2008 R2
1. Click Action>Hyper-V Settings...

2. Change the drive letter under Virtual Hard Disk and Virtual Machines to the drive that you wish your

virtual machines to be copied on to, and click OK.

Click Action=>Import Virtual Machine...

4. Select Copy the virtual machine (create a new unique ID), and click the Duplicate all files so the same
virtual machine can be imported again check box.

5. Click Browse.

w
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7.
8.

Browse to where you exported your VM, select the VM Folder you wish to copy out, and click Select
Folder.

Click Import

Repeat this task until you have imported all five VMs.

Installing the clients

In addition to setting up the server under test, we also had to set up the client systems we show in Figure 7. Both
the WebBench and LoadSim workloads require test clients. Each CSU requires one consolidated test client.

Installing the WebBench 5.0 test client system

To run WebBench, we needed two types of test systems. WebBench clients use WebBench software engines to
send HTTP requests to stress the server under test. A WebBench controller system manages the clients during
the benchmark runs. Both systems run on the same physical client.

Installing a WebBench 5.0 client

1.

Install Windows Server 2003 Enterprise Edition 32-bit. Type mailclient as the system name.

2. Install Windows Server 2003 Service Pack 2 with the default settings.

3. Open the Network Connections window by right-clicking My Network Places and selecting Properties from
the menu.

4. Right-click the network connection, and click Properties.

5. Highlight TCP/IP, and select Properties.

6. Select Use the following IP address, and enter the following information: IP address 192.168.11.211
Subnet 255.255.255.0

7. Click OK to close the two Properties windows.

8. Insert the WebBench CD, and open it with Windows Explorer.

9. Run setup.exe from the location /wb50/client/setup.exe.

10. Click Next through all screens, a process that accepts the defaults.

11. When the installation completes, copy the WebBench shortcut icon from the open window to the system’s
desktop.

12. With WordPad, open the file c:\Windows\system32\drivers\etc\hosts.

13. After the last text in that file, type the following additional lines, and click Save:
e 192.168.11.100 controller
° 192.168.11.215 server

14. Close the hosts file and Windows Explorer.

15. Run /wb50/controlr/setup.exe.

16. Click Next through the installation, which accepts all default options.

17. With Windows Explorer, open C:\WebBench\Controller\Clientids\client.cdb.

18. Add the client’s IP address to the top of the file. Press Tab twice, and type 1

19. Click File>Save, and close the client.cdb file.

20. Copy vConsolidate.tst file from the vCON\WebBench directory to
C:\WebBench\controller\suites\WebBench.

21. Copy ecommerce_cgi_template_w2k3.tst and ecommerce_cgi_template_w2k3.wl files from
vCON\WebBench directory to C:\WebBench\controller\suites\WebBench.

22. Copy all files from \vCON_framework\WebBench_daemon in the vConsolidate package to C:\.

23. Select Start>All Programs—>PC Magazine Benchmarks—>WebBench 5.0 Controller.

24. From the Suites drop-down menu, click Create/Edit.

25. Browse to the vConsolidate.tst file, and click Open.

26. Highlight the first Mix, and click Edit.

27. On the General tab, change Engines per client to 8.

28. Select the Workload tab.

29. Change the number of threads to 1.

30. Click Copy across.
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31.
32.
33.

Select the Engines per client and Number of threads check boxes, and click OK.
Click OK to close the suites windows.
Close the WebBench Controller window.

Installing the mail test client
Install the mail client on the same consolidated client at WebBench client and controller. We performed the
following steps to set up the system:

©CoN>OThwWN =

Right-click My Computer, and select Properties.

Click the Computer Name tab.

Click Change.

Select Domain in the member of section, and type the domain vcon . com into the text box.

In the pop-up window, type administrator for user name, password for password, and click OK.
At the Welcome to the domain screen, click OK.

When the warning that you must restart dialog appears, click OK.

Click OK to close the System Properties window.

Click Yes to the pop-up message to restart the computer.

. Log into the domain by typing administrator and password

. Install Microsoft Outlook 2003 with the default settings. (Outlook 2003 doesn’t require any configuration.)
. Install LoadSim 2003 by double-clicking the loadsim.msi installation file. Accept all defaults.

. Open LoadSim 2003, and make sure no error messages appear.

. Copy c:\Program Files\LoadSim\Islog.exe file to a floppy disk or USB thumb drive. You will need this file

during the vConsolidate controller installation.

Configuring LoadSim 2003

1. Start LoadSim by clicking Start Menu—>All Programs—>Exchange LoadSim—->LoadSim 2003.
2. From the LoadSim menu bar, select Configuration->Topology Properties.
3. Click the Servers tab.
4. Inthe left pane, click the + next to the name of this server.
5. Inthe left pane, select the First Storage Group.
6. In the right pane, set the number of users to 500.
7. Select the Security and Credentials tab.
8. Leave the Credentials choice set to Login to users using the account LoadSim is running on.
9. In the password portion of the tab, type the password Passwordil and click OK.
10. From the LoadSim menu bar, select Configuration>Test Properties, and click Add.
11. Click Customize Tasks.
12. Select the Initialization tab.
13. Enter the following settings:
e Number of messages in Inbox: 150
e Number of messages in Deleted items: 1
e Number of new folders: 2
e Messages per new folder: 100
e Number of Smart Folders: 3
e Number of Rules in Inbox: 5
e Initialize Free/Busy Information: Leave it unselected
e Number of appointments: 25
e Number of contacts: 64
14. Click OK.
15. In the Test Properties window, change the run time to 2 hours, and click OK.
16. From the LoadSim menu bar, choose File>Save As.
17. Save a backup copy of the simulation file as C:\loadsim.sim.
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18.

19.
20.

21.

22.
23.

From the LoadSim menu bar, select Run->Create Topology, and wait until the Creating Users and
Creating DLs tasks complete.

From the LoadSim menu bar, select Run—>Initialize Test.

When a dialog box appears with the question Do you want to initialize Public Folders from this client
machine?, click Yes.

The run is complete when the bottom left corner of the LoadSim window shows Status: Idle. This task
typically takes about 2 to 3 hours to complete.

From the LoadSim menu bar, select Run—>Run Simulation.

The run is complete when the bottom left corner of the LoadSim window shows Status: Idle. This task
typically takes a little over 2 hours to complete.

Backing up the mail and database server files

For test consistency, we created backup copies of the Mail and Database Server’s database files. Once we set up
LoadSim and created its initial mail database, we backed up that database so we could have clean copies for
each test. We did the same on the database server. We created a folder we named Backup on the C: drive of
each VM for the backup files. For testing, we used scripts to perform a restore before each run so that we started
at the same point for each run. Examples of the scripts we used for a 7-CSU restore are the following:

Restoring 7 CSU script
Set CSU COUNT=7

Set SHUTDOWN_CMD=-r

Set PREPEXCHANGE=restore_ reboot exchange.bat
Set PREPSYSBENCH=restore sysbench.bat

Set DBSERVER WAIT=90

Set /A I=1
Set /A J=1

pause

: CLIENT_LOOP

shutdown $SHUTDOWN CMD% -f -t 5 -m \\192.168.%J%1.110
Set /A J+=1

if %J% LEQ %CSU COUNT$ GOTO _CLIENT LOOP

echo give your clients a couple of minutes to restart

pause

: CSU_LOOP
copy %PREPSYSBENCH% \\DBServer%I%\C$\servicecontent.bat /y
copy %PREPEXCHANGE% \\192.168.%I%1.115\C$\servicecontent.bat /vy

shutdown %SHUTDOWN_CMD% -f -t %DBSERVER_WAIT% -m \\DBServer$%I$%
shutdown $%SHUTDOWN CMD% -f -t 5 -m \\JavaServer%I%
shutdown $%SHUTDOWN CMD% -f -t 5 -m \\IdleServer%I%

del /F /0O \\192.168.%I%1.110\CS\WebBench\Controller\Results\vConsolidate. *

shutdown $%SHUTDOWN CMD% -f -t 5 -m \\192.168.%I%1.215

Set /A TI+=1
if $I% LEQ $CSU _COUNT$ GOTO _CSU_LOOP

pause
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Restoring SysBench script

net stop mssglserver

sleep 1

del /F /Q "C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data\sbtest*"
sleep 1

copy /Y /V C:\sysbench backup\sbtest* "C:\Program Files\Microsoft SQL
Server\MSSQL.1\MSSQL\Data\"

sleep 1

net start mssqglserver

Restoring Exchange script
dismount.vbs

sleep 5

del /F /Q E:\publ.*
del /F /Q E:\privl.*

copy /Y "E:\backup\publ.*" E:\
copy /Y "E:\backup\privli.*" E:\

mount .vbs

REM - While we are waiting for the main Exchange services to stop,
REM - Some peripheral services will be closed in the background.
start /min net stop MSExchangeMGMT /yes

start /min net stop RESvc /yes

start /min net stop POP3Svc /yes

start /min net stop IMAP4Svc /yes

start /min net stop NntpSvec /yes

start /min net stop SMTPSVC /yes

REM - Stop Exchange main services before shutdown to avoid timing conflicts.

net stop MSExchangeES /yes
net stop MSExchangeIS /yes
net stop MSExchangeMTA /yes
net stop MSExchangeSA /yes

REM - Well, why not stop other services in the background just for fun?
REM - Stopping IISADMIN will stop other dependant services like W3SVC, and
HTTPFilter (SSL).

start /min net stop IISADMIN /yes

start /min net stop MSSEARCH /yes

start /min net stop Spooler /yes

shutdown -r -f -t 15

vConsolidate controller

We used a separate physical system, the controller, to manage the vConsolidate workload. We used a single
section both for this function and as the controller system for the first CSU’s WebBench benchmark. This
controller offers a graphical user interface (GUI) to start and stop the vConsolidate workload. After the workload
finishes, the controller copies the independent benchmark result files from all the VMs and combines their results
into a single file, results.txt. We performed the following steps to set up this vConsolidate controller:

1. With Windows Explorer, create a C:\vCON directory.
2. Copy all files from the \WCON_framework\controller directory of the vConsolidate package to c:\\vCON.
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3. Copy the Islog.exe file the mail client installation created to c:\vCON.

The vCON directory contains a Profiles sub-directory. The Profiles directory contains four sample profiles,
1CSU.profile, 2CSU.profile, 3CSU.profile, 4CSU.profile, and a blank template, Profile.template. vConsolidate
uses these files to identify the number and name of the VMs a test should include. An example 1CSU.profile
contains the following:

<Profile>

<Name>1 CSU</Name>
<CSUNum>1</CSUNum>

<Servers>

<DB>

<0S>Win</0S>
<Host>DBServerl</Host>

</DB>

<Loadsim>
<Host>192.168.202.110</Host>
</Loadsim>

<Java>

<0S>Win</0S>
<Host>JavaServerl</Host>
</Java>

<WebBench>
<Host>192.168.202.210</Host>
</WebBench>

</Servers>

</Profile>

Running vConsolidate

To run vConsolidate and get consistent results, we first prepared the VMs with clean copies of the test data. We
outline below the process for getting ready to run the workload. We then explain how to start and stop the
workload. Finally, we detail how to find its results.

Preparing the vConsolidate run
Prior to running vConsolidate, we restore the backup Mail and Database Server backup files, so we can ensure
consistent results.

Verifying connectivity and setting profiles
1. Open a command prompt by selecting Start->Run, type cmd and click OK.
2. Type the following commands at command prompt:

e net use \\loadsim client IP Address\c$

e net use \\JavaServerl\c$

e net use \\DBServerl\c$

e net use \\WebBench Controller IP Address\c$

3. Verify that the vConsolidate controller can read and write remote files to all VMs with the following
commands:

With Windows Explorer, create an empty file, dummy . txt
Copy dummy.txt \\loadsim client IP Address\c$
Copy dummy.txt \\JavaServerl\c$

Copy dummy.txt \\DBServerl\c$
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4.

e Copy dummy.txt \\WebBench Controller IP Address\c$

Modify the profile file by entering the VM name or IP address appropriate to each VM in the test. For the
one-CSU test, enter four server names or IP addresses; for the two-CSU test, enter eight.

Startlng and stopping vConsolidate

oAM=

®© N

9.

10.
11.
12.
13.
14.
15.

16.
17.
18.
19.
20.

21.

Shut down all VMs by selecting Start->Shutdown and then selecting Shutdown from the window.

In the left pane of the Virtual Infrastructure Client window, highlight localhost.localdomain.

In the right pane, select the Summary tab.

Under the Commands section, click Reboot.

While the server is rebooting, reboot all clients in the test bed.

After the Hyper-V Server has rebooted, log in using the Virtual Infrastructure Client, and start all VMs in
the test.

Once the VMs are active, log the LoadSim client(s) into the appropriate domain(s).

Double-click Daemon.exe manually on the following VMs and systems:

DataServer1
JavaServer1
LoadSim client
WebBench controller

Start the WebBench Controller application on the WebBench controller system by selecting Start->All
Programs—->PC Magazine Benchmarks.

In the WebBench Controller application, choose the Clients menu, and click Start Log In.

Double-click the WebBench 5.0 client shortcut on all the WebBench test client desktops.

Once all the client machines have logged into WebBench, click OK.

At the Would you like to add a test suite? dialog, click Yes.

In the Select a test suite window, choose vConsolidate.tst, and click OK.

When the Would you like to start executing the test suites? window appears, do NOT click Yes or No. The
vConsolidate controller application will handle that task at the start of the test.

Double-click c:\vCON\vconsolidate.exe.

Select the profile name you want to run.

Wait 15 minutes to allow all virtual machines and Hyper-V Server to load all processes and become
completely idle.

Click start.

The vConsolidate controller software will immediately start the LoadSim application. LoadSim will take
about 60 to 80 seconds to log 500 users onto the Exchange Server. The remaining benchmarks will start
once all the LoadSim users have logged in.

After about 30 minutes, the vConsolidate controller application will stop the benchmark and collect their
results.

Locating and interpreting the results file
vConsolidate places all result data in the following location:

¢:\vCON\vCONMM-dd-hh-mm

where MM is the month, dd is the day, hh is the hour, and mm is the minute of the test. The file result.txt in that
directory summarizes all the results. It contains the following information:

Java transaction score
Database transaction score
Mail transaction score

Web server throughput
Start and stop times
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Figure 8 shows an example results.txt file for a test with one CSU. We have labeled each score with a brief
description. See the Test results section for more information on how we used these individual results to calculate
each server’s overall score on the workload.

B result.txt

File Edit Format View Help

ul v
JFT sum—32354673 1 V@ Score
DB Trans Number=231093— Datahase Score

—————————— TEMP. TXT
wWeighted Avg 60 14015

—————————— VCONSOLIDATE. RLG

A,4_client, 8,/1706. 959|, 6908069. 563, 0,
A,4_client, 8,/1622.183|, 6576748. 875, 0,
A,4_client, 8,1558. 235], 6241389, 500, 0,
11:44:39.921
12:15:44.140

WebBench Score

LoadSim Scaore

122 215 132 68 <--"score"

Figure 8: Example of vConsolidate results file.
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Appendix A — Test server configuration information

Figure 9 provides detailed information about each of the test server configurations, which we list in alphabetical

order by processor name.

Server configuration

Microsoft
Windows Server
2008 Enterprise

Edition SP2 on
Intel Xeon
processor E5450-
based server

Microsoft
Windows Server
2008 Enterprise

Edition SP2 on
Intel Xeon
processor X5570-
based server

Microsoft
Windows Server
2008 Enterprise

Edition R2 on

Intel Xeon
processor X5570-

based server

General processor setup

Number of processor packages 2 2 2
Number of cores per processor package 4 4 4
Number of hardware threads per core 1 2 2
System Power Management Policy Balanced Balanced Balanced
CPU
Vendor Intel Intel Intel
Name Xeon E5450 Xeon X5570 Xeon X5570
Stepping EOQ DO DO
Socket type LGA 771 LGA 1366 LGA 1366
Core frequency (GHz) 3.00 2.93 2.93
Front-side bus frequency (MHz) 1,333 6.4 GT/s (QPI) 6.4 GT/s (QPI)
32 KB + 32 KB 32 KB + 32 KB 32 KB + 32 KB
L1 cache
(per core) (per core) (per core)
L2 cache :é;v'B (2x6,144 | 1 B (4 x 256 KB) | 1 MB (4 x 256 KB)
L3 cache N/A 1x8 MB 1x8 MB
Platform
Supermicro Supermicro Supermicro
Vendor and model number SuperServer SuperServer SuperServer
6025B-TR+
Motherboard model number X7DB8 X8DTN+ X8DTN+
Motherboard chipset Intel 5000P Intel 5520 Intel 5520
Motherboard revision number B1 1.02 1.02
Pheonix American American
BIOS name and version Technologies LTD | Megatrends 1.0b Megatrends 1.0b
2.1 (06/23/2008) (05/04/2009) (05/04/2009)
Turbo Mode Turbo Mode
Disabled Disabled
BIOS settings Default Intel Virtualization Intel Virtualization
Technology Technology
Enabled Enabled
Memory module(s)
Kingston Micron Micron
Vendor and model number KVR667D2D4F5/4 | MT36JSZF51272P | MT36JSZF51272P
Gl Y-1G1D1BA Y-1G1D1BA

Type

DDR2 PC2-5300

DDR3 PC3-8500

DDR3 PC3-8500

Speed (MHz)

667

1,066

1,066

Speed in the system currently running @
(MHZz)

667

800

800
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Microsoft
Windows Server
2008 Enterprise

Microsoft
Windows Server
2008 Enterprise

Microsoft
Windows Server
2008 Enterprise

Server configuration Edition SP2 on Edition SP2 on Edition R2 on
Intel Xeon Intel Xeon Intel Xeon
processor E5450- | processor X5570- | processor X5570-
based server based server based server
Timing/Latency (tCL-tRCD-iRP-tRASmin) 5-5-5-15 6-6-6-16 6-6-6-16

RAM module size

64 GB (16 x 4 GB)

72 GB (18 x 4 GB)

72 GB (18 x 4 GB)

Number of RAM modules

16

18

18

Chip organization Double-sided Double-sided Double-sided
Hard drive
Vendor and model number Western Digital Western Digital Western Digital
WD1600AAJS WD1600AAJS WD1600AAJS
Number of disks in system 2 2 2
Size (GB) 160 160 160
Buffer size (MB) 8 8 8
RPM 7,200 7,200 7,200
Type SATA SATA SATA
Controller intel ESB2 SATA | (1ELCORTRER 1 | 1C110 SATA RAID
RAID Controller
Controller Controller
Driver Intel 8.8.0.1009 Intel 8.0.0.1039 Intel 8.6.2.1012
(2/11/2009) (04/15/2008) (04/08/2009)

Operating system

Microsoft Windows

Microsoft Windows

Microsoft Windows
Server 2008

Name and version Server ?008 3 Server 2008 3 Enterprise Edition
Enterprise Edition Enterprise Edition R2

Build number 6002 6002 7229

Service Pack SP2 SP2 N/A

File system NTFS NTFS NTFS

Kernel ACPI x64-based ACPI x64-based ACPI x64-based
PC PC PC

Language English English English

Graphics

Vendor and model number ATI ES1000 ATI ES1000 ATI ES1000

Chipset ES1000 ES1000 ES1000

Type Integrated Integrated Integrated

Memory size (MB) 32 32 32

Resolution 1,024 x 768 1,024 x 768 1,024 x 768

Network card/subsystem

Network adaptor 1

Vendor and model number

Intel PRO/1000 EB

Intel 82576 Gigabit

Intel 82576 Gigabit
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Network Adapter Ethernet Adapter Ethernet Adapter
Type Integrated Integrated Integrated
Driver version Intel 9.12.36.0 Intel 10.6.15.0 Microsoft 11.0.5.22
(12/4/2008) (03/05/2009) (04/06/2009)
Network adaptor 2
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Server configuration

Microsoft
Windows Server
2008 Enterprise

Edition SP2 on
Intel Xeon
processor E5450-
based server

Microsoft
Windows Server
2008 Enterprise

Edition SP2 on
Intel Xeon
processor X5570-
based server

Microsoft
Windows Server
2008 Enterprise

Edition R2 on

Intel Xeon
processor X5570-

based server

Intel PRO/1000 PT

2 x Intel PRO/1000

2 x Intel PRO/1000

Vendor and model number Dual Port Server PT Quad Port PT Quad Port
Adapter Server Adapter Server Adapter

Type PCI-Express PCI-Express PCI-Express

Driver version Intel 9.12.36.0 Microsoft 9.11.5.7 Microsoft 9.13.4.10
(12/4/2008) (06/21/2006) (03/26/2009)

Optical drive

Vendor and model number

Matshita DVD-

Slimtype DVD A

Slimtype DVD A

ROM SR-8178 DS8A1P DS8A1P
USB ports
Number 4 4 4
Type USB 2.0 USB 2.0 USB 2.0
Power supplies
Total number 2 2 2
Wattage of each (W) 700 805 805
Cooling fans
Total number 3 3 3
Dimensions 3I"x3 3I"x3 3x3
Voltage (V) 12 12 12
Amps (A) 1.1 1.1 1.1

Figure 9: Detailed information for the three test server configurations.
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Appendix B — Complete test results

Figures 10 through 12 show the complete results for all runs we completed on the three test systems.

Microsoft Windows Server 2008 Enterprise Edition SP2 on Intel Xeon processor E5450-based server

| Score | CPU utilization

1CSU

Run 1 | 1.37 | 61.32
2 CSUs

Run 1 | 1.92 | 92.56
3 CSUs

Run 1 2.07 98.01

Run 2 2.06 98.03

Run 3 2.07 98.17

Figure 10: Complete results for all runs on Microsoft Windows Server 2008 Enterprise Edition SP2 running on the Intel Xeon
processor E5450-based server. Higher scores are better.

Microsoft Windows Server 2008 Enterprise Edition SP2 on Intel Xeon processor X5570-based server

| Score | CPU utilization

1CSU

Run 1 | 1.32 | 31.41
2 CSUs

Run 1 | 2.58 | 60.44
3 CSUs

Run 1 | 3.05 | 75.80
4 CSUs

Run 1 | 3.38 | 84.10
5 CSUs

Run 1 | 3.66 | 91.68
6 CSUs

Run 1 | 3.86 | 93.55
7 CSUs

Run 1 | 3.97 | 96.24
8 CSUs

Run 1 4.14 98.34

Run 2 4.11 98.21

Run 3 3.94 96.96

Figure 11: Complete results for all runs on Microsoft Windows Server 2008 Enterprise Edition SP2 running on the Intel Xeon
processor X5570-based server. Higher scores are better.
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Microsoft Windows Server 2008 Enterprise Edition R2 on Intel Xeon processor X5570-based server

| Score | CPU utilization

1CSU

Run 1 | 1.64 | 2477
2 CSUs

Run 1 | 3.23 | 49.13
3 CSUs

Run 1 | 4.30 | 72.61
4 CSUs

Run 1 | 4.88 | 87.80
5 CSUs

Run 1 | 5.19 | 93.81
6 CSUs

Run 1 | 5.40 | 96.76
7 CSUs

Run 1 | 5.49 | 98.34
8 CSUs

Run 1 5.60 99.10

Run 2 5.65 99.00

Run 3 5.64 99.05

Figure 12: Complete results for all runs on Microsoft Windows Server 2008 Enterprise Edition R2 running on the Intel Xeon

processor X5570-based server. Higher scores are better.
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